Upgrading OpenLDAP databases

For some reason every time that I upgrade OpenLDAP, it refuses to start, because the LDAP databases are not getting upgraded.

I have been fixing this with:

db_recover -v -h /var/lib/ldap/
db_upgrade -v -h /var/lib/ldap/*.bdb
db_checkpoint -v -h /var/lib/ldap/ -1

Leave a Reply

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>